Dienstag, 24. Februar 2009

Namespace abgrenzen

Über eine interessante Schreibweise bin ich neulich gestoßen. Nämlich die, den Namespace für lokale Variablen innerhalb einer Methode zu begrenzen:

public void test() {

{
String s = "test";
//... tu was mit dem String
}

// String s ist hier nicht mehr im Zugriff.
}

Mit dieser Schreibweise lassen sich Variablen voneinander abgrenzen, in dem diese nur für einen bestimmten Bereich der Methode sichtbar gehalten werden. Fängt man aber mit einer funktionalen Abgrenzung innerhalb einer Methode an, scheint es mir eher angebracht, diese Bereiche, die ohnehin einen eignen Namespace erhalten, gleich in eine neue Methode auszulagern, was gleichzeitig die Chance birgt, der Methode einen sprechenden Namen zu geben und damit die Lesbarkeit zu verbessern. Außerdem erhöht man damit die Wahrscheinlichkeit, dass wer anders im Team die Methode findet und Wiederverwendet, anstelle eine eigene neu zu schreiben. Nach einigem Abwegen habe ich für mich jedenfalls entschieden, dass ich diese Schreibweise nicht mag.

Keine Kommentare:

Kommentar veröffentlichen